Read and Review Automation Anywhere Documentation

Automation Anywhere Version 11.3

Close Contents

Contents

Open Contents

Dependencies for supported services

  • Updated: 5/15/2020
    • 11.3.x
    • Explore
    • Enterprise

Dependencies for supported services

Control Room and Enterprise Client have additional third party requirements depending upon the Automation Anywhere Enterprise options you choose. Some are optionally installed with Automation Anywhere Enterprise deployment. Some require an Automation Anywhere specific plug-in.

CAUTION: Exclude anti-virus scans from running in the Automation Anywhere local repository because they interfere with running bots.

Control Room dependencies for supported options

Install the listed dependency if you plan to use the listed supported option.

Dependency Version Supported option
HTML For Microsoft Azure: Use Load Balancer, not Application Gateway.
Microsoft Active Directory

Configure as either IDaaS or IaaS.

For IaaS use Windows 2016.
Microsoft Internet Information Services (IIS) web server version 8 or later. Lightweight Directory Access Protocol (LDAP) and Kerberos supported.
Microsoft .NET Framework[1] Required. version 4.6, 4.6.1, or 4.7

4.6.1 only supported on Windows 8.1 or Windows Server 2012 R2.

Version 11.3.1.2Microsoft OLEDB Driver for Microsoft SQL Server For Microsoft Azure installations.
Version 11.3.1.2Microsoft Visual C++ Redistributable for Visual Studio version 2013 or later For Microsoft Azure installations .
Java Database Connectivity (JBDC) driver ForOracle Database.
Security Assertion Markup Language (SAML) version 2.0 For Single Sign-On (SSO).
Note 1

On new machines, physical or virtual, install Microsoft .NET Framework before your install Microsoft Office. This ensures required Primary Interop Assemblies (PIA) redistributables are installed.

Enterprise Client dependencies for supported bot tasks

Install the listed dependency for the listed Enterprise Client or bot option.

Dependency Automation Anywhere Plug-in Enterprise Client or Bot option

Version 11.3.3ABBYY FineReader Engine version 11 or 12

For capturing images.

Version 11.3.3Adobe ActionScript (Advanced Flex) version 3.0

Automation Anywhere Flex plug-in

For recording Web tasks.

Technology support for Bot Creator.

Not supported with Windows 10 and MetaBots, Windows Server 2012, or Windows Server 2016.

AISense For talk to text.

Version 11.3.2Citrix Receiver

Version 4.4 LTSR or later

Automation Anywhere Citrix plug-in

Automation Anywhere Citrix remote agent, Automation Anywhere Enterprise Version 11.3.2 or later

For using Citrix server resident apps or installing Enterprise Client.

Version 11.3.2Citrix Virtual Apps version 6.5 or later

Automation Anywhere Citrix plug-in

Automation Anywhere Citrix remote agent, Automation Anywhere Enterprise Version 11.3.2 or later

For using Citrix server resident apps.

Version 11.3.2Citrix XenDesktop Version 7.15 LTSR

Automation Anywhere Citrix plug-in

Automation Anywhere Citrix remote agent, Automation Anywhere Enterprise Version 11.3.2 or later

For using Citrix server resident apps or installing Enterprise Client.

Version 11.3.3HTML

For recording Web tasks. Technology support for Bot Creator.

Version 11.3.2IBM WebSEAL

For reverse proxy.

Trusted client certificate required on all Enterprise Client machines.

Version 11.3.3LinguaSol Linguify

For language translation.

Version 11.3.3Microsoft Active Accessibility (MSAA)

To import/export datasets Technology support for Bot Creator.
Microsoft Active Directory

Configure as either IDaaS or IaaS.

For IaaS, use Windows 2016.
Microsoft Office Document Imaging (MODI) version12.0 For OCR engine.
Microsoft .NET Framework version 4.6, 4.6.1, 4.7, or 4.8. 4.6.1 only supported on Windows 8.1 or Windows Server 2012 R2.
Microsoft Visual C++ Redistributable for Visual Studio version 2015 or later For Control Room installation.
Windows Presentation Foundation (WPF) For recording Web tasks.

Oracle Java versions:

1.6 (JRE 1.6.0_45),

1.7 (JRE 1.7.0_80), or

1.8(JRE 1.8_111) - Desktop and Web.

For recording Web tasks.

Desktop (standalone) Java applications (running on JRE 6 or later versions) do not require the Automation Anywhere Java plug-in.

Technology support for Bot Creator.

Orchestrator For bot deployments on non-persistent VDIs. Download and install any third-party tool that supports API execution.
Proxy service For web service commands.

Version 11.3.3SAP DLL for SAP Business Application Programming Interface (BAPI) integration version 3.0.21.0

To automate tasks in SAP.

Version 11.3.3PowerBuilder Platform version 10.5

Silverlight version 5.1.x

For recording Web tasks.

Not supported in Windows 10 and MetaBots.
SMB File Share

Configure as PaaS (50 GB minimum).

For Microsoft Azure installations, use Microsoft Azure File Share.
Tesseract Optical Character Reader (Tesseract OCR) version 5.0 For OCR engine.

Terminal emulator

Types:

  • ANSI (default)
  • Version 11.3.3IBM-5555-XXX DBCS
  • VT Series VT100
  • Version 11.3.3VT Series VT220
  • TN3270
  • TN5250
To access and control terminal hosts.
UIAutomation Technology support for Bot Creator.
VMware Horizon version 4.8.0 For installing the Enterprise Client.
Windows Communication Foundation (WCF), Transport Layer Security (TLS) For secure communications.
Windows Server Essentials Media Pack, Media Foundation enabled version 1.2 For Image Recognition command.

See Windows Server Essential Media Pack configuration.

Send Feedback