Lire et examiner la documentation Automation Anywhere

Fermer les contenus

Contenus

Ouvrir les contenus

Enregistrement d'un Robot de tâches

  • Mis à jour le : 11/20/2019
    • 11.3.x
    • Exploration
    • Enterprise

Enregistrement d'un Robot de tâches

Les options Enregistrer en tant que fichier texte et Enregistrer en tant que fichier XML permettent d'enregistrer un Robot de tâches en mode d'édition dans l'éditeur de tâches. Lorsque vous sauvegardez le Robot de tâches (fichier atmx) au format XML, les informations sur les propriétés de tâche, les variables et les commandes sont enregistrées. Cependant, si vous l’enregistrez comme fichier texte, ces informations ne sont pas enregistrées.

Enregistrer un robot : en tant que fichier texte

  1. Cliquez sur Fichier > Enregistrer en tant que fichier texte.
  2. Entrez le nom du fichier dans le champ Select the file (Sélectionner le fichier) ou cliquez sur Browse... (Parcourir) pour sélectionner un emplacement de votre choix à l'aide de l'Explorateur Windows.
  3. Cliquez sur Enregistrer.

    Le fichier s'ouvre.

    Remarque : Version 11.3.4Le texte « Disabled: True » (Désactivé :Vrai) est ajouté aux lignes désactivées dans le Robot de tâches .
  4. Vérifiez le contenu et cliquez sur Enregistrer.

Enregistrer un robot : en tant que fichier XML à partir de Espace de travail

  1. Cliquez sur File (Fichier) > Save as XML Flie (Enregistrer en tant que fichier XML).
  2. Entrez un nom de fichier dans le champ Select the file (Sélectionner le fichier).

    Si vous laissez le champ vide, le système utilise le nom de la tâche dans le dossier par défaut dans lequel la tâche est enregistrée.

  3. Cliquez sur Ouvrir.
    Conseil : Cliquez sur Browse…(Parcourir...) pour sélectionner un emplacement de votre choix à l'aide de l'Explorateur Windows :
  4. Cliquez sur Enregistrer.
  5. Cliquez sur OK.

Enregistrement d’un robot : en tant que fichier XML à partir de la ligne de commande

Pour enregistrer un robot en tant que fichier XML depuis la ligne de commande, vous devez ouvrir une session en tant que créateur de robots.

  1. Lancez la fenêtre de commande.
  2. Saisissez la commande suivante pour enregistrer le fichier à un emplacement spécifique :
    <application path> /token /<sd> or <sf>: <source directory path or source filename> /<dd> ou <df>: <destination directory path or destination filename>
    Par exemple :
    C:\Program Files (x86)\ 11.2\Client\AAWorkbench.exe /export /sf: C:\Server-Files\Loop.atmx /df:"D:\Task-Repository\Loop.xml
  3. Sélectionnez l’un des paramètres facultatifs.
    Paramètre : Description :
    jeton Exportation
    sf Fichier source.

    Il s'agit d'un paramètre obligatoire.

    sd Répertoire source.

    Il s'agit d'un paramètre obligatoire.

    df Fichier de destination.

    Il s'agit d'un paramètre facultatif !

    dd Répertoire de destination.

    Il s'agit d'un paramètre facultatif !

    Les types du paramètre source et du paramètre de destination doivent être identiques. Par exemple, sf doit être utilisé avec df.

    Par défaut, s'il existe un fichier portant le même nom, il est remplacé.

Structure de fichier XML

Les fichiers XML fournissent les détails des tâches dans trois sections principales :

  1. Propriétés de la tâche
  2. Variables : chacune des variables se trouve dans le nœud <Variable>
  3. Commandes : chacune des commandes se trouve dans le nœud <Command>

Enregistrer sous, copier et ajouter une nouvelle tâche lorsque le contrôle de version est activé

Si vous indiquez un nouveau nom de fichier à l'aide de l'une des options Save As(Enregistrer sous), Copy (Copier) ou New (Nouveau), seul un nom unique peut être ajouté dans le dossier dans lequel le fichier est créé. Vous ne pouvez pas ajouter un nom de fichier existant.

Version 11.3.3

Enregistrement d’un robot protégé

L’option File-> Save As (Fichier -> Enregistrer sous) est désactivée pour protéger les droits de Propriété intellectuelle (PI) du créateur original du Collaborateur numérique ou du robot :.

Vous ne pouvez pas enregistrer un robot protégé en tant que fichier XML depuis la ligne de commande.

Envoyer le commentaire